Degraded Performance
Incident Report for CxEngage
Resolved
This incident is resolved.
Posted Jun 27, 2022 - 21:12 UTC
Monitoring
We are monitoring changes implemented on the platform and seeing traffic return to normal.
Posted Jun 27, 2022 - 20:53 UTC
Investigating
We are currently investigating an issue with degraded performance
Posted Jun 27, 2022 - 20:42 UTC
This incident affected: CxEngage - North America Region (Voice Services).