CxEngage Degraded Performance
Incident Report for CxEngage
Resolved
This incident has been resolved
Posted Aug 15, 2022 - 18:14 UTC
Monitoring
A fix has been implemented, and we are monitoring for further impact
Posted Aug 15, 2022 - 17:52 UTC
Investigating
We are currently investigating an issue
Posted Aug 15, 2022 - 17:21 UTC
This incident affected: CxEngage - North America Region (Reporting).