Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 22, 2025 - 12:00 UTC
Scheduled
Our engineering team will be performing standard maintenance on CxEngage backend services
Who: All tenants for CxEngage What: Backend Services Where: CxEngage Infrastructure at Enghouse Data Centers What do I need to do?: No additional customer actions will be needed
US = +1 800.793.0549 UK = +44 770.015.6785 NZ = +64 4.8318.707 AU = +61 2.8015.5378
Posted Mar 21, 2025 - 16:14 UTC
This scheduled maintenance affected: CxEngage - North America Region (Voice Services, API Services, Reporting, Messaging Services, CxEngage Agent UI, CxQM Web, CxQM Recorder, CxEngage Admin User Interface, Internal Tools) and CxEngage - Europe Region (Voice Services, API Services, Reporting, Messaging Services, CxEngage Agent UI, CxQM Web, CxQM Recorder, CxEngage Admin User Interface, Internal Tools).