Call Center Service Interruption
Incident Report for CxEngage
Resolved
This incident has been resolved, and all services are confirmed to be restored to normal.
Posted Oct 16, 2023 - 09:58 UTC
Update
We are continuing to monitor for any further issues.
Posted Oct 16, 2023 - 08:43 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 16, 2023 - 08:43 UTC
Update
We are continuing to investigate this issue.
Posted Oct 16, 2023 - 08:32 UTC
Investigating
We are currently investigating the issue with interrupted calls and login sessions.
Posted Oct 16, 2023 - 08:32 UTC
This incident affected: CxEngage - North America Region (Voice Services) and CxEngage - Europe Region (Voice Services).