CxEngage | Failed Inbound Calls
Incident Report for CxEngage
Resolved
This incident has been resolved.
Posted May 07, 2019 - 16:42 UTC
Monitoring
Serenova Engineers have implemented the fix and we are monitoring the results at this time.
Posted May 07, 2019 - 16:29 UTC
Identified
The issue has been identified and Serenova Engineers are implementing a fix.
Posted May 07, 2019 - 16:23 UTC
Investigating
Serenova Engineers are currently investigating an issue that is resulting in intermittent failed inbound calls. Customers may experience that calls ring four to five times, however the call is not delivered.
Posted May 07, 2019 - 16:09 UTC
This incident affected: CxEngage - North America Region (Voice Services).