Calls Dropped or Dead Air
Incident Report for CxEngage
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 20:17 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 22, 2024 - 16:30 UTC
Update
We are continuing to investigate this issue.
Posted Apr 22, 2024 - 16:08 UTC
Update
Our engineering team is actively working on identifying and resolving the cause. We aim to provide another update within 1 hour or as soon as more information becomes available.
Posted Apr 22, 2024 - 16:05 UTC
Update
We have confirmed a carrier related issue for inbound and outbound calls. We are working with the vendor at the moment.
Posted Apr 22, 2024 - 15:14 UTC
Update
We are continuing to investigate this issue.
Posted Apr 22, 2024 - 15:13 UTC
Update
We are continuing to investigate this issue.
Posted Apr 22, 2024 - 15:12 UTC
Investigating
We are currently investigating this issue.
Posted Apr 22, 2024 - 15:09 UTC
This incident affected: CxEngage - North America Region (Voice Services) and CxEngage - Europe Region (Voice Services).