CxEngage Degraded performance on Inbound and Outbound calls
Incident Report for CxEngage
Resolved
This incident has been resolved.
Posted Jun 25, 2019 - 21:23 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 25, 2019 - 19:20 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 25, 2019 - 19:18 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 25, 2019 - 19:01 UTC
This incident affected: CxEngage - North America Region (Voice Services).